首 页  >>  E商学院  >>  zencart百科  >>  ZenCart 1.39h升级到1.5.0或1.51方法

ZenCart 1.39h升级到1.5.0或1.51方法

环境要求

登陆后台,导航中Version 菜单,检查下自己空间是否瞒住zencart 1.5最低要求

PHP 5.2.14 或以上版本
MySQL 4.1.3 或以上版本
Apache 2.0 或以上版本

前期准备

备份网站数据文件和数据库,便于升级过程中出现问题可以恢复,很重要滴

插件准备

理出自己网站所用的插件名单,到zencart官网上找到他们最新的1.5版的插件,如果插件没有更新,可以在本地测试下老版插件在1.5版中是否可以正常使用

如果不能使用,就只能现删除此插件,或者等待作者更新了

记录非模板部分的的二次开发修改的地方,便于升级后,在改过来

升级

1.下载对应语言版本1.5.0版zencart,然后解压后,将admin文件夹改名为自己后台目录名称

2.然后上传所有文件到网站根目录,浏览器中运行http://www.xxx.com/zc_install/

continue,下一步

同意协议,continue,下一步,拉到页面最下面

选择Database Upgrade,升级数据库


填上管理员账号密码后,点击Update Database Now

升级后,提示一些警告信息,一般都是跳过执行的的sql语句,不用管它,点击Done With updates完成升级

登陆网站后台Configuration -->Website Maintenance-->Down for Maintenance: ON/OFF改为false

删除文件列表,1.5版后不需要这些文件

/admin/admin.php - replaced with new suite of files such asusers.php

2 /admin/email_welcome.php
3 /admin/includes/fckeditor.php (use the CKEditor addonifneeded)
4 /admin/includes/htmlarea.php (htmlarea removed from core. Use preferred addonifneeded)
5 /admin/includes/tld.txt
6 /admin/includes/boxes/ (entire folder and subfolders)
7 /admin/includes/functions/compatibility.php (unusedfile)
8 /admin/includes/languages/english/cache.php
9 /admin/includes/languages/english/email_welcome.php
10 /admin/includes/languages/english/extra_definitions/editors_list.php (emptied -filecan be deleted)
11 /admin/includes/languages/english/extra_definitions/onlyFor139.php (emptied -filecan be deleted)
12 /editors/htmlarea (entire folder)
13 /includes/languages/english/tell_a_friend.php
14 /includes/languages/english/modules/shipping/ups.php
15 /includes/languages/english/modules/shipping/usps.php
16 /includes/modules/pages/tell_a_friend/header_php.php (the whole folder)
17 /includes/modules/sideboxes/tell_a_friend.php
18 /includes/modules/shipping/ups.php
19 /includes/modules/shipping/usps.php
20 /includes/templates/template_default/common/tpl_header_test_info.php
21 /includes/templates/template_default/sideboxes/tpl_tell_a_friend.php
22 /includes/templates/template_default/templates/tpl_tell_a_friend_default.php

老版本配置文件也可以用,但是1.5.0版配置和老版本有些不同,可以在本地全新安装1.5 版,然后对照修改成1.5版

升级插件

将自己网站需要的插件升级

测试

测试网店,从注册下单支付邮件等全部测试一遍,看有没什么问题




点击次数:6175  发布日期:2013-12-13  【打印此页】  【关闭