首 页  >>  E商学院  >>  PHP新发现  >>  cPanel面板使用PHP5.2版本运行

cPanel面板使用PHP5.2版本运行

有个网站的空间是使用cPanel面板,而现在,国外主流的主机商的cPanel面板中的PHP版本都自动升级到5.3版本。

但是国内的很多程序仍然是使用PHP5.2,而且是使用zend编译的,如果是PHP5.3版本,那么程序将无法运行。

怎 么办?在这方面,感觉cPanel比DirectAdmin要强大,cPanel只要一句话就可以继续使用PHP5.2版本运行程序,而且和PHP5.3 版本同时运行,互不干扰。我记得DirectAdmin只能将PHP版本降级,或者升级,重新编译,也就是只能选择其中一个版本来运行。

现在就说说cPanel面板如何支持PHP5.2版本,方法如下:

在网站根目录下面建一个.htaccess文件,然后里面加上这句:
AddHandler application/x-httpd-php52 .php

如果要使用PHP5.3,这样写:
AddHandler application/x-httpd-php53 .php

如果要使用PHP5.4,这样写:
AddHandler application/x-httpd-php54 .php

赶快试试吧。

点击次数:632  发布日期:2014-12-06  【打印此页】  【关闭